Gravity BTP-S80 Printer Setup
General Notes:
You must use the special cable that is included in the box when this printer is received. More info on the cable is here:
https://idealpos.freshdesk.com/a/solutions/articles/24000076410
You must use the Setup program to establish and configure this printer.
The red light could be a paper alarm. This can be disabled in the setup program.
As of 24 July 2023, USB is not supported for this printer.
Problem:
Printer is performing a full cut on receipts.
Cause:
Printer default settings is set to full cut not partial cut.
Idealpos V8 Build 5 and Idealpos V7 Build 22 currently don't send a partial cut command to the printer from Network Printers.
Solution 1:
Change the Cutter Type on the printer itself.
There is a utility, which will reside in C:\IdealPosFiles\Utilities\Printer Utilities\BTP-S80\Beta_PrinterUtility V1.66
Also available for retrieval below.
Run Utility.exe
Select Port Set
Change Printer Name to BTP-S80
Change Baud Rate to 115200 if connected with a COM Port
Select COM number.
Press OK

Select Eeprom Set
Press Get Settings from Printer
Change Cutter Type from Default to Partial Cut
Press Save Settings To Printer
This should then return a success prompt
Solution 2:
Configure the printer in POS Terminal Settings > Receipt Printer.
Enter in the following settings:

Perform a test print. This test will be completely cut off.
Going back to the Sales screen and performing a Receipt Print function, the receipt will not cut completely but be held on ready for removal - ie Partial Cut.
Idealpos V8 Build 6
From V8 B6 onwards this printer can be connected in Network Printers with the following settings. This sends the Partial Cut command to the printer.