GeneralScan GS M100BT and the Stock Manage app
Problem:
When using the Stock Manage app with the Bluetooth GeneralScan GS M100BT scanner, the message 'Stock Item not found' displays when a valid barcode is scanned. If the same barcode is scanned with the camera scanner on the device, it works.
Cause:
Some M100BT scanners have a built-in suffix for CR/LF enabled in their firmware which is adding a character when scanning. A Factory Reset will not change this, as it is firmware enabled.
Solution:
In the full book that is supplied with the scanner, there is a barcode option to disable 'On-Board Built-In Suffix for CRLF'. After scanning this barcode, the scanner will work correctly.